I'm making a game

Formerly: Game name that I havent decided yet.
non trek themed game in development.

Moderator: Crook

User avatar
Kai_Undead_Assassin
Posts: 572
Joined: Mon Apr 02, 2001 12:00 am
Location: Earth
Contact:

Post by Kai_Undead_Assassin » Fri Jun 01, 2007 12:22 am

No problem. Hope ya get the bugs worked out soon. This game looks like it's gonna be sweet.

User avatar
Texas Ranger
Posts: 2006
Joined: Mon May 28, 2001 12:00 pm
Location: Johnstone, Renfrewshire Scotland
Contact:

Post by Texas Ranger » Fri Jun 01, 2007 10:04 am

Here is what i got at 10 o'clock

i manually put the IP in for the 2nd pic. this was the second time i ran it so it looks like when you exit it is leaving the ports open.
Attachments
crook-app-2.jpg
crook-app-1.jpg

User avatar
Pierce 2: The Sequel
Posts: 922
Joined: Wed Dec 08, 2004 1:00 pm
Location: I'm from Iowa--I only work in outer space

Post by Pierce 2: The Sequel » Fri Jun 01, 2007 12:20 pm

When I hit send, it told me "An invalid IP address was specified." It was my internal IP that was sent...

User avatar
Crook
Posts: 3900
Joined: Thu Nov 02, 2000 1:00 pm
Location: Oxfordshire, UK
Contact:

Post by Crook » Fri Jun 01, 2007 1:16 pm

Yeah, 'server offline' in that first pic. It's difficult to coordinate over forums with lots of time between postings - I have to leave the PC here idle while I wait for someone to maybe have a try with it. This is one of the reasons for wanting a forum, so I can enlist peoples help a bit easier and get them on IM.

Thanks for trying anyway.




EDIT:

Ok, here's a v2. It should now read your external IP (and bloody hell that's difficult with NAT being transparent!). The good thing about this is that it seems to solve all my IPv6 problems - with it all being external, it's all IPv4 for now - it'll be a few years before we all have to switch.

Instructions:

Open it up.
Check that it reads an IP on the left (62.56.75.119 it is today). If it reads 'SERVER OFFLINE', then I've set it like that to stop you trying and trying when I haven't got the server running.
Check that your external IP is on the right, not an internal network IP. You can check with http://www.whatismyipaddress.com/ if you like.
Hit start
Type a message to replace 'TEST MESSAGE'
Hit send.
Attachments
Client_test_v2.zip
(10.04 KiB) Downloaded 67 times
<a href="http://www.andrewcrook.co.uk/empire/Empire_home.shtml" target="_blank">Empire - an online multiverse game</a>


<a href="http://www.c-digital-art.co.uk" target="_blank">www.c-digital-art.co.uk</a>
<img src="http://www.andrewcrook.co.uk/images/c-d ... _trans.gif" border="0" alt="" />

Locked

Return to “Empire”